Splunk Enterprise

O365 Disable MFA Analytics

saskn
New Member

https://research.splunk.com/cloud/c783dd98-c703-4252-9e8a-f19d9f5c949e/

when i give this command Oper...



`o365_management_activity` Operation="Disable Strong Authentication." 
| stats count earliest(_time) as firstTime latest(_time) as lastTime by UserType Operation UserId ResultStatus object 
| rename UserType AS user_type, Operation AS action, UserId AS src_user, object AS user, ResultStatus AS result 
| `security_content_ctime(firstTime)` 
| `security_content_ctime(lastTime)` 
| `o365_disable_mfa_filter`
as per the

 

Labels (1)
0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @saskn,

If the query works when Operation!="Disable Strong Authentication.", it shows no user disabled MFA. Normally, you have no results if all users are using MFA.

 

If this reply helps you an upvote and "Accept as Solution" is appreciated.
0 Karma

saskn
New Member

the above query not working but when i Operation!="Disable Strong Authentication."  getting enabled mfa users list.

i have already ingested the Splunk logs and completed the macro creation

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...