Splunk Enterprise

O365 Disable MFA Analytics

saskn
New Member

https://research.splunk.com/cloud/c783dd98-c703-4252-9e8a-f19d9f5c949e/

when i give this command Oper...



`o365_management_activity` Operation="Disable Strong Authentication." 
| stats count earliest(_time) as firstTime latest(_time) as lastTime by UserType Operation UserId ResultStatus object 
| rename UserType AS user_type, Operation AS action, UserId AS src_user, object AS user, ResultStatus AS result 
| `security_content_ctime(firstTime)` 
| `security_content_ctime(lastTime)` 
| `o365_disable_mfa_filter`
as per the

 

Labels (1)
0 Karma

scelikok
SplunkTrust
SplunkTrust

Hi @saskn,

If the query works when Operation!="Disable Strong Authentication.", it shows no user disabled MFA. Normally, you have no results if all users are using MFA.

 

If this reply helps you an upvote and "Accept as Solution" is appreciated.
0 Karma

saskn
New Member

the above query not working but when i Operation!="Disable Strong Authentication."  getting enabled mfa users list.

i have already ingested the Splunk logs and completed the macro creation

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...