Splunk Enterprise

How to enable Web UI in Indexer

vksplunk1
Explorer

Hi Good Morning ,

Web UI in indexer is not starting though the following setting in place in ..../system/default/web.conf

 

[settings]

# enable/disable the appserver
startwebserver = 1

# First party apps:
splunk_dashboard_app_name = splunk-dashboard-studio

# enable/disable splunk dashboard app feature
enable_splunk_dashboard_app_feature = true

# port number tag is missing or 0 the server will NOT start an http listener
# this is the port used for both SSL and non-SSL (we only have 1 port now).
httpport = 8000

 

Then added a ..../system/local/web.conf with the following to see if it enable but still the web UI is disabled:
enableSplunkWebSSL = true

 

Any help is greatly appreciated

Labels (2)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

Use btool to see the effective settings (verify if they're not overwritten somewhere else).

Check with netstat or ss that splunkd listens on port 8000.

0 Karma

Roy_9
Motivator

@vksplunk1 did you checked the local firewalls or iptables?

 if telnet is connecting on port 8000 there isn't this problem and also do check for errors in internal logs.

0 Karma
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...