Splunk Enterprise

How to enable Web UI in Indexer

vksplunk1
Explorer

Hi Good Morning ,

Web UI in indexer is not starting though the following setting in place in ..../system/default/web.conf

 

[settings]

# enable/disable the appserver
startwebserver = 1

# First party apps:
splunk_dashboard_app_name = splunk-dashboard-studio

# enable/disable splunk dashboard app feature
enable_splunk_dashboard_app_feature = true

# port number tag is missing or 0 the server will NOT start an http listener
# this is the port used for both SSL and non-SSL (we only have 1 port now).
httpport = 8000

 

Then added a ..../system/local/web.conf with the following to see if it enable but still the web UI is disabled:
enableSplunkWebSSL = true

 

Any help is greatly appreciated

Labels (2)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

Use btool to see the effective settings (verify if they're not overwritten somewhere else).

Check with netstat or ss that splunkd listens on port 8000.

0 Karma

Roy_9
Motivator

@vksplunk1 did you checked the local firewalls or iptables?

 if telnet is connecting on port 8000 there isn't this problem and also do check for errors in internal logs.

0 Karma
Get Updates on the Splunk Community!

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...

Edge Processor Scaling, Energy & Manufacturing Use Cases, and More New Articles on ...

Splunk Lantern is a Splunk customer success center that provides advice from Splunk experts on valuable data ...