Splunk Enterprise Security

Splunk Add-on for ServiceNow configuration

pslattery23
New Member

Morning!
Looking for some assistance with an error that I am receiving when I try and configure the Splunk add-on for ServiceNow from Splunk base.
When setting up the "ServiceNow account" information - Add ServiceNow Account in the Splunk Web interface, I receive the following error.
ERROR: Unable to reach server at https://InstanceName.service-now.com. Check configurations and network settings.

Account has been created in ServiceNow with the following roles
import_transformer, rest_api_explorer, sn_sec_splunk_v2.api_account_access, sn_si.analyst, sn_si.integration_user, soap

URL has been verified as the "Base URL" to the instance
User name and password have been verified by the ServiceNow team. Password has been reset and retested as well to ensure accuracy

alt text

0 Karma

ivanreis
Builder

check this link with information about how you can setup the proxy and edit the configuration from CLI.
you have to edit the service_now.conf at $SPLUNK_HOME/etc/apps/Splunk_TA_snow/local. If the file is not under local folder, you can copy the service_now.conf from default to local and run the proper configuration

https://docs.splunk.com/Documentation/AddOns/released/ServiceNow/Setuptheadd-on

0 Karma

hkubavat_splunk
Splunk Employee
Splunk Employee

Make sure you have not configured any proxy settings. Try to ping the URL if it accessible or not from the server you are trying to configure.

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!