Splunk AppDynamics

What does App Agent node property values set to 0 do

CommunityUser
Splunk Employee
Splunk Employee

I'm cross checking all our App Server Agent Node Properties in all our environments and I've found some max properties set to 0.  For example.

max-error-snapshots-per-minute=0

The default is 5 for this property but does anyone know what setting this value to 0 will do. Will it stop all error snapshots, or is this effectively no limit?  I believe we're still getting error snapshots so I'm wondering if it  may be the latter. 

Labels (3)
0 Karma

Arun_Dasetty
Super Champion

Hi Stewart, 

We request to set value to less value like 1 or 2 for target node property instead zero(0), setting value to zero will not work as per internal requests observations and is expected 0 is not right value, Hope that answers.

Regards,

Arun

0 Karma

CommunityUser
Splunk Employee
Splunk Employee

I wasn't trying to change the number to a low number, what I am wondering is now that I've found a parameter with an invalid value in our configuration what will the agent currenty be doing with this. 

Will this generate an error and the property be missed, or will the agent ignore the errror and use the default value, or is it possible that something else will occur. 

Thanks

0 Karma

Arun_Dasetty
Super Champion

Hi,

If you are using recent agent versions, we see invalid args could be ignored though error will raise in agent logs it will not affect agent functionality, However we request to provide any node property values as per values suggested or listed in docs in UI, Hope that answers.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...