Security

Why do I get an error when trying to start TCP input with SSL?

benlc
Path Finder

I got the following Error when trying to Start TCPInput with SSL:

ERROR SSLCommon - can't load CA certificates from /opt/splunk/etc/apps/XXXX/certs/XXXX.crt

Very straight forward config:

inputs.conf

[splunktcp-ssl:9997]
disabled = 0

[SSL]
sslPassword = XXXXXXXXXXXXX
serverCert = $SPLUNK_HOME/etc/apps/XXXXXXXX/certs/XXXXXX.pem
sslVersions = tls, -tls1.0
requireClientCert = true

server.conf:
[sslConfig]
sslRootCAPath = $SPLUNK_HOME/etc/apps/XXXXX/certs/XXXXX.crt

0 Karma
1 Solution

benlc
Path Finder

My CA-Certificate startet with

-----BEGIN TRUSTED CERTIFICATE-----

and ended in:
-----END TRUSTED CERTIFICATE-----

As soon as I deleted "TRUSTED" and made the CA-Cert look like the examples:
-----BEGIN CERTIFICATE-----
and
-----END CERTIFICATE-----

It finally worked. There is not much more info to link to.

View solution in original post

0 Karma

benlc
Path Finder

My CA-Certificate startet with

-----BEGIN TRUSTED CERTIFICATE-----

and ended in:
-----END TRUSTED CERTIFICATE-----

As soon as I deleted "TRUSTED" and made the CA-Cert look like the examples:
-----BEGIN CERTIFICATE-----
and
-----END CERTIFICATE-----

It finally worked. There is not much more info to link to.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...