Security

Using the Splunk Enterprise Trial, why is localhost:8000 not getting loaded?

hyderabadt
Engager

I am using a Splunk Enterprise Trial and Splunk Web http://localhost:8000/en-US/app/launcher/home is not getting loaded.

gtattersall
Engager

Localhost:8001 worked for me and not the default :8000 page that opened after installing it through the GUI. After doing some digging I saw that another process was already listening on that port so, Splunk must have incremented the port by one.

I would test 8000-8005!

richgalloway
SplunkTrust
SplunkTrust

@gtattersall This thread is almost 4 years old. You stand a better chance of getting help by posting a new question.

---
If this reply helps you, an upvote would be appreciated.
0 Karma

markn0119
New Member

mjscoggins,

Your path showed me how to restart Splunk. I can now connect and login to Enterprise localhost.

Thank you,

0 Karma

markn0119
New Member

by changed to the bin directory and restarted splunk with the command 'splunk restart'

0 Karma

gyslainlatsa
Motivator

hi,
splunkd not yet started

go to CLI , write $SPLUNK_HOME/bin/splunk startor $SPLUNK_HOME/bin/splunkd start or use restart to replace start`.

if splunkd already already running? write $SPLUNK_HOME/bin/splunk restart

after go http://localhost:8000/en-US/app/launcher/home

it's going to work

markn0119
New Member

Hi gyslainlatsa,

Thank you for your help. I can connect and login to Enterprise localhost 🙂

0 Karma

mjscoggins
Explorer

I was getting connection refused in the browser. I was able to start splunk in Windows Services, but received the following errors when attempting the CLI method. Any idea why? I was not logged in as an admin.

C:\Program Files\Splunk\bin>splunk start

Splunk> Like an F-18, bro.

Checking prerequisites...
Checking http port [8000]: open
Checking mgmt port [8089]: open
Checking appserver port [127.0.0.1:8065]: open
ERROR - Failed opening "C:\Program Files\Splunk\var\log\splunk\splunkd-utility.log": Access is denied.
Checking configuration... Done.
Failed to open splunk.secret 'C:\Program Files\Splunk\etc\auth\splunk.secret' file. Some passwords will not work. errno=Access is denied.
Unable to read 'C:\Program Files\Splunk\etc\auth\splunk.secret' file.
Checking critical directories... Done
ERROR - Failed opening "C:\Program Files\Splunk\var\log\splunk\splunkd-utility.log": Access is denied.
Checking indexes...
homePath='C:\Program Files\Splunk\var\lib\splunk\audit\db' of index=_audit on unusable filesystem.
Validating databases (splunkd validatedb) failed with code '1'. If you cannot resolve the issue(s) above after consulting documentation, please file a case online at http://www.splunk.com/page/submit_issue

0 Karma

sushmitha1295
New Member

Thank you @mjscoggins . It worked.

C:\Program Files\Splunk\bin
Follow this breadcrumb and click on splunk.exe will be able to login successfully.

0 Karma

fenderignacio
Engager

I had a similar problem from opening the splunk web to having Access denied when starting splunk in cmd.

Solution worked for me-
Open cmd as administrator. Go to Splunk bin path (i.e. C:\Program Files\Splunk\bin) from cmd.

C:\Program Files\Splunk\bin>splunk start

Splunk> Be an IT superhero. Go home early.

Checking prerequisites...
Checking http port [8001]: open
Checking mgmt port [8089]: open
Checking appserver port [127.0.0.1:8065]: open
Checking kvstore port [8191]: open
Checking configuration... Done.
Checking critical directories... Done
Checking indexes...
(skipping validation of index paths because not running as LocalSystem)
Validated: _audit _internal _introspection _telemetry _thefishbucket history main summary
Done
Checking filesystem compatibility... Done
Checking conf files for problems...
Done
Checking default conf files for edits...
Validating installed files against hashes from 'C:\Program Files\Splunk\splunk-7.1.3-51d9cac7b837-windows-64-manifest'
All installed files intact.
Done
All preliminary checks passed.

Starting splunk server daemon (splunkd)...

Splunkd: Starting (pid 18772)
Done

Waiting for web server at http://127.0.0.1:8001 to be available.. Done

If you get stuck, we're here to help.
Look for answers here: http://docs.splunk.com

nidhig0909
New Member

Thank you! it was very useful. I am now able to start SPLUNK, although the default port should be changed to 8001 on the link.

Thanks

0 Karma

richgalloway
SplunkTrust
SplunkTrust

@mjscoggins This thread is more than a year old. For better chances at a helpful response, you should post a new question.

---
If this reply helps you, an upvote would be appreciated.
0 Karma

mjscoggins
Explorer

Thanks, I was wondering about that. In some of the other user groups I post in age of the original post isn't a problem. I'll post this as a new question.

0 Karma

Asusgalopp2
New Member

I have the same problem and have tried the solution above, but it is still not working. I have Windows 10 home 64 bit. Is it a reason?

0 Karma

cindykullerhome
New Member

I have the same problem, same operating system and '$SPLUNK_HOME' is not recognized.

0 Karma

pdhoke
New Member

hi,
splunkd not yet started

go to CLI , write $SPLUNK_HOME/bin/splunk startor $SPLUNK_HOME/bin/splunkd start or use restart to replace start`.

if splunkd already already running? write $SPLUNK_HOME/bin/splunk restart

after go http://localhost:8000/en-US/app/launcher/home

it's going to work

This solution is worked for me.

0 Karma

Jonahgoldsmith
New Member

If ya have ZoneAlarm / Malewarebytes etc on your windoze platform, Or runnin' a VEE EMM , Go into Services settings and Put Splunkd on Automatic(delayed Start) or put in Manual Start as above ..... If you are using many of the cool new Splunk apps like PCAP FILES ... , be sure to set SPLUNK_HOME C:\Programfiles... yadayada \bin ....

0 Karma

cramasta
Builder

Are you sure splunk is running?

Try running.
$SPLUNK_HOME/bin/./splunk status

.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!