Security

Splunk enterprise webserver not available after SSL install

afolabia
Path Finder

I'm doing a new install on a Linux Centos 7 VM . We have our own CA that issue our certs. After installing my SSL Certs and creating the web.conf in system/local to use the certs, and restarting splunk i get Waiting for web server at https://127.0.0.1:8000 to be available... and then web server not available. If I point back to web.conf in default, the error goes away and splunk is available. SSL is enable and port is also included in the .conf file. What am i missing?

Tags (1)
0 Karma
1 Solution

afolabia
Path Finder

Thanks. It was a certificate issue. I had to extract the keys and convert the cert.

View solution in original post

0 Karma

afolabia
Path Finder

Thanks. It was a certificate issue. I had to extract the keys and convert the cert.

0 Karma

skalliger
Motivator

If the web server is not starting, it's most likely due to an error with either the certificate/the certificate chain or in decrypting it. Please take a look into the splunkd.log - there should be ERRORs visible saying why the web server can't start.

Skalli

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...