Reporting

Why am I receiving following layout error while generating a PDF locally?

dlovett
Path Finder
2014-10-06 13:26:37,617 Eastern Daylight Time ERROR pdfgen_endpoint:237 - Exception raised while trying to render "M 24 Hour Report Log" to PDF. Flowable <Table@0x03056948 8 rows x 11 cols(tallest row 574)>...(424.0 x 1768), tallest cell 574.0 points,  too large on page 2 in frame 'normal'(456.0 x 636.0*) of template 'Later' Traceback (most recent call last):   File "D:\Splunk\etc\system\bin\pdfgen_endpoint.py", line 233, in _render
    self._pdfRenderer.save()   File "D:\Splunk\Python-2.7\Lib\site-packages\splunk\pdf\pdfrenderer.py", line 419, in save
    doc.build(self._story, onFirstPage=_footer, onLaterPages=_footer)   File "D:\Splunk\Python-2.7\Lib\site-packages\reportlab\platypus\doctemplate.py", line 1129, in build
    BaseDocTemplate.build(self,flowables, canvasmaker=canvasmaker)   File "D:\Splunk\Python-2.7\Lib\site-packages\reportlab\platypus\doctemplate.py", line 892, in build
    self.handle_flowable(flowables)   File "D:\Splunk\Python-2.7\Lib\site-packages\reportlab\platypus\doctemplate.py", line 805, in handle_flowable
    raise LayoutError(ident) LayoutError: Flowable <Table@0x03056948 8 rows x 11 cols(tallest row 574)>...(424.0 x 1768), tallest cell 574.0 points,  too large on page 2 in frame 'normal'(456.0 x 636.0*) of template 'Later'
Tags (3)
1 Solution

dlovett
Path Finder

fixed it. had to go to settings and change the default settings for pdf. After setting the default size to "Legal" and format to "landscape" the error went away

View solution in original post

dlovett
Path Finder

fixed it. had to go to settings and change the default settings for pdf. After setting the default size to "Legal" and format to "landscape" the error went away

View solution in original post

.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!