Monitoring Splunk

Splunk v6 client.py - suds error in binding.py

BP9906
Builder

I installed Bigfix App for Splunk and all was working with Splunk v5.x, now after upgrading to Splunk v6.0.4, the client.py script fails to execute. When I run manually I see the same error as SOS reports. Why is this causing an issue?

/opt/splunk/bin/splunk cmd python ./bin/clients.py


ERROR:root:Encountered Exception in GetRelevanceResult:
Traceback (most recent call last):
File "/opt/splunk/etc/apps/bigfix/bin/../lib/bigfix/soap/bfconnector.py", line 44, in run
self.results = self.client.service.GetRelevanceResult(expr.format(url=self.url, user=self.user), self.user, self.passwd)
File "/opt/splunk/etc/apps/bigfix/bin/../lib/suds/client.py", line 542, in call
return client.invoke(args, kwargs)
File "/opt/splunk/etc/apps/bigfix/bin/../lib/suds/client.py", line 602, in invoke
result = self.send(soapenv)
File "/opt/splunk/etc/apps/bigfix/bin/../lib/suds/client.py", line 643, in send
result = self.succeeded(binding, reply.message)
File "/opt/splunk/etc/apps/bigfix/bin/../lib/suds/client.py", line 678, in succeeded
reply, result = binding.get_reply(self.method, reply)
File "/opt/splunk/etc/apps/bigfix/bin/../lib/suds/bindings/binding.py", line 151, in get_reply
self.detect_fault(soapbody)
File "/opt/splunk/etc/apps/bigfix/bin/../lib/suds/bindings/binding.py", line 182, in detect_fault
raise WebFault(p, fault)
WebFault: Server raised fault: 'Singular expression refers to nonexistent object.'

Tags (1)
0 Karma
1 Solution

BP9906
Builder

I resolved this issue.

I uncommented the lines in the top of: /opt/splunk/etc/apps/bigfix/lib/bigfix/soap/bfconnector.py

Which then gives all data via std out in a shell so you can see everything and where it errors. This helped me locate my issue and resolve it.

I wish the debugging info was present in the docs! 🙂

View solution in original post

0 Karma

BP9906
Builder

I resolved this issue.

I uncommented the lines in the top of: /opt/splunk/etc/apps/bigfix/lib/bigfix/soap/bfconnector.py

Which then gives all data via std out in a shell so you can see everything and where it errors. This helped me locate my issue and resolve it.

I wish the debugging info was present in the docs! 🙂

0 Karma

kannanmallan
New Member

hi, could you pls let me know how this was resolved?> i have the same issue .

0 Karma

jypyking
Explorer

Hi, in my case it's not entirely fixed. As stated above I've removed some parts of the relevance, but as such I'm missing some data. As BP9906 said, the best way is to launch the script in the shell and troubleshooting the errors.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

@jypyking, This thread is more than 3 years old with an accepted answer. For a better chance at getting a solution, you should post a new question.

---
If this reply helps you, an upvote would be appreciated.
0 Karma

jypyking
Explorer

Hi BP9906,

I'm experiencing the same error, I've enabled debug but I can't find where the error comes from.
What did you change on your side ?

Thanks

0 Karma

jypyking
Explorer

I've identified that removing those relevances allow the script to run without errors:

  • " full_os=%22" & concatenation "," of unique values of (values of (results (bes property "Full Operating System Name and Service Pack Level - Windows", it); results (bes property "OS Name - Unix", it); results (bes property "OS Name - Mac OS X", it)) of item 0 of it) & "%22" &

  • " client_version=" & value of result(item 0 of it, bes property "BES Client Version") &

  • " relay_version=" & (if (value of result(item 0 of it, bes property "BES Relay Version") = "Not Installed") or (value of result(item 0 of it, bes property "BES Relay Version") = "N/A") then "" else (value of result(item 0 of it, bes property "BES Relay Version"))) &

  • " server_version=" & (if (value of result(item 0 of it, bes property "BES Server Version") = "Not Installed") or (value of result(item 0 of it, bes property "BES Server Version") = "N/A") then "" else (value of result(item 0 of it, bes property "BES Server Version"))) &

  • " soap_url=" & "https://FQDN/?wsdl" &

I'm gonna try debug them and post the results here.

JP

0 Karma

kannanmallan
New Member

i am facing the same error. please help to resolve this..thank you

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>