Monitoring Splunk

Query to get Percentage using two Queries?

Deprasad
Path Finder

I've 2 queries, 1 will give the the total no of events and the other will give the counts by error type.
I'm trying to join the two queries so that I can get the percentage of each error type.

Query 1:
index=app  "ResponseLoggingFilter" "Operation"
| stats count as Total_Transaction

Query 2:
index=app "ResponseLoggingFilter" "Operation"  NOT "OK" NOT "1041"
| rex "(?:.+message\"\:\")(?<Error_Message>.+)(?:\"\,)"
| stats count by Error_Message

Labels (1)
0 Karma
1 Solution

Deprasad
Path Finder

Thanks for this query @richgalloway ! 

It worked. Further I added the below piece of query to get the percentage.


| eval Error_Percentage=round(100*count/Total_Transaction,2)."%"
| table Error_Message,count, Error_Percentage

View solution in original post

richgalloway
SplunkTrust
SplunkTrust

See if this helps

index=app  "ResponseLoggingFilter" "Operation"
| eventstats count as Total_Transaction
| rex "(?:.+message\"\:\")(?<Error_Message>.+)(?:\"\,)"
| eval Error_Message = if(match(_raw, "OK") OR match(_raw, "1041"), null(), Error_Message)
| stats max(Total_Transaction) as Total_Transaction, count by Error_Message
---
If this reply helps you, Karma would be appreciated.
0 Karma

Deprasad
Path Finder

Thanks for this query @richgalloway ! 

It worked. Further I added the below piece of query to get the percentage.


| eval Error_Percentage=round(100*count/Total_Transaction,2)."%"
| table Error_Message,count, Error_Percentage

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Ditch the Manual Grind: Building AI Agents with Splunk

Ditch the Manual Grind: Building AI Agents with Splunk Let’s be real: your team’s time is being eaten alive. ...

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...