Knowledge Management

Skipped searches

VijaySrrie
Builder

Hi All,

I am working on skipped searches, what is the difference between below 2?

1) The maximum number of concurrent historical scheduled searches on this cluster has been reached

2) The maximum number of concurrent running jobs for this historical scheduled search on this cluster has been reached

 

Tags (1)
0 Karma
1 Solution

Tom_Lundie
Contributor

Hi,

The wording is quite tricky but I will do my best to explain:

1) The maximum number of concurrent historical scheduled searches on this cluster has been reached:

Platform-level. Essentially,  the Splunk platform has reached its concurrent search limit as defined by the concurrency settings in limits.conf. For example, if the limit is five, you might have six different searches all scheduled at once, triggering this error.

2) The maximum number of concurrent running jobs for this historical scheduled search on this cluster has been reached

This is defined on a per-search level under max_concurrent within savedsearches.conf (advanced search settings). It is one by default. This means that one particular search has been scheduled whilst previous instances of that same search is still running. So for example, you schedule a particular search to run every two minutes but it takes six minutes to run. Splunk starts it, and two minutes later, goes to schedule it for a second time but its still running, throwing the error.

As a tip, 1) is typically caused by incorrectly scheduled searches all scheduled for the same time. Whereas 2) is caused by a particular search being scheduled too frequently or running for longer than expected, causing it to overlap with itself.

View solution in original post

Tom_Lundie
Contributor

Hi,

The wording is quite tricky but I will do my best to explain:

1) The maximum number of concurrent historical scheduled searches on this cluster has been reached:

Platform-level. Essentially,  the Splunk platform has reached its concurrent search limit as defined by the concurrency settings in limits.conf. For example, if the limit is five, you might have six different searches all scheduled at once, triggering this error.

2) The maximum number of concurrent running jobs for this historical scheduled search on this cluster has been reached

This is defined on a per-search level under max_concurrent within savedsearches.conf (advanced search settings). It is one by default. This means that one particular search has been scheduled whilst previous instances of that same search is still running. So for example, you schedule a particular search to run every two minutes but it takes six minutes to run. Splunk starts it, and two minutes later, goes to schedule it for a second time but its still running, throwing the error.

As a tip, 1) is typically caused by incorrectly scheduled searches all scheduled for the same time. Whereas 2) is caused by a particular search being scheduled too frequently or running for longer than expected, causing it to overlap with itself.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...