Knowledge Management

List index from a datamodel

kuriakose
Explorer

Hi,

 

can someone one help me with an SPL so that I can list the indexes of a datamodel.

datamodel name - authentication.malware

 

Appreciate your help in advance.

Labels (1)
0 Karma
1 Solution

richgalloway
SplunkTrust
SplunkTrust

It's not clear what you're looking for.  To find which indexes are used by a datamodel:

| tstats count from datamodel=<datamodelname> by index

 

---
If this reply helps you, Karma would be appreciated.

View solution in original post

kuriakose
Explorer

You are awesome. Thanks a lot.

0 Karma

richgalloway
SplunkTrust
SplunkTrust

It's not clear what you're looking for.  To find which indexes are used by a datamodel:

| tstats count from datamodel=<datamodelname> by index

 

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...

Network to App: Observability Unlocked [May & June Series]

In today’s digital landscape, your environment is no longer confined to the data center. It spans complex ...

SPL2 Deep Dives, AppDynamics Integrations, SAML Made Simple and Much More on Splunk ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...