Knowledge Management

How to list which data sources have datamodels

Zarack
Engager

I need to list which data sources have datamodels, I tried a few ways but none of them were effective, can you help me please.

Best regards

Valderlúcio.

Labels (1)
Tags (2)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

It would help to know what you've already tried.  Have you looked at it the other way, that is, what sources do each DM use?

| tstats count from datamodel=<DM name> by source

You  should be able to combine that with

| rest /services/data/models

and map to list the sources used by all datamodels.

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...