Knowledge Management

Aliases not working

DanAlexander
Communicator

Hi All,

I am having an issue creating an alias simply going from DestinationPort to dest_port for SysMon EventID 3

I have tested:

 

index=my_index source=Sysmon

| eval destinationPort=dest_port

 

I have seen in Splunk TA Sysmon that there is FIELDALIAS-dest_port=DestinationPort AS dest_port

but still cannot convert DestinationPort to dest_port at Search time.

Any suggestions, please? There are no other apps contradicting the precedence.

Thank you!

Labels (2)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

And remember that for search-time operations it's important if you have enough permissions for the app (that should not typically be the issue here but it's worth checking out if all else fails)

richgalloway
SplunkTrust
SplunkTrust

Make sure the sourcetype on your data matches that for the FIELDALIAS.

---
If this reply helps you, Karma would be appreciated.
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

What’s New in Splunk AI: Volume 02

Welcome to the second edition of “What’s New in Splunk AI” where we look at the latest and greatest updates, ...

Splunk App Dev Quarterly Roundup: AI, Agents, and Innovation!

Another quarter, another wave of innovation. From complex integrations to pushing the limits ...

Value Insights: Now Generally Available in the CMC

Organizations are under pressure to move faster, control cost, expand AI adoption, and prove value with more ...