Installation
Highlighted

Migrate Splunk 5 from 4.1.7 on Linux

Communicator

Hello

Are there any experiences for migrating splunk form versions earlier 4.2. ?
In the install manual there is a hint that it is very easy to migrate from 4.2 to 5, but nothing what I have to look if I migrate from previous versions.

Could somone bring light into the dark?
Thanks
Rob

Tags (1)
0 Karma
Highlighted

Re: Migrate Splunk 5 from 4.1.7 on Linux

Splunk Employee
Splunk Employee

If you are upgrading from a Splunk version prior to 4.2 you'll need to follow the docs to upgrade to 4.2 first, then upgrade to Splunk 5.0.

Find the appropriate details for upgrading to 4.2 here.

View solution in original post

Highlighted

Re: Migrate Splunk 5 from 4.1.7 on Linux

Splunk Employee
Splunk Employee

sdaniels is correct. You'll need to first upgrade to 4.2, per the 5.0 upgrade path.

Upgrading directly to 5.0 from versions older than 4.2 is not officially supported. If you are running a version of Splunk earlier than 4.2, then you should upgrade to
4.2 first before attempting an upgrade to 5.0. Read "About upgrading to 4.2 READ THIS FIRST" for specific details on how to upgrade to version 4.2.

Note: You can find older releases in the top nav bar of the main download page.