Installation

Getting errors when installing Splunk in Linux environment.

sambed
Explorer

While I install in Linux environment, I have below error on start Splunk:

splunk: /home/build/build-src/kimono/src/launcher/fnmatch.c:151: fnmatch: Assertion `fnm->type == CHAR_SET' failed.
Aborted (core dumped)

I am with splunk-6.6.1-aeae3fe0c5af-linux-2.6-x86_64.rpm

Labels (2)

iamkilarunaresh
Explorer

I am facing the same issue, Please let me know if you find a resolution for it. Thanks!

0 Karma

koshyk
Super Champion

seems like a bug

0 Karma

sambed
Explorer

I would appreciate , if you could help me to fix it .
Or any suggestion.

0 Karma

pappjr
Path Finder

I would recommend opening a Splunk support ticket on that. Perhaps try installing an older version of Splunk like 6.5.2 (most stable previous release)

0 Karma

jkat54
SplunkTrust
SplunkTrust

Are you installing as root?

Are you installing with rpm -i splunk-6.6.1-aeae3fe0c5af-linux-2.6-x86_64.rpm or another method?

What version of linux are you using (uname -a)?

0 Karma

sambed
Explorer

Yeah it belongs
2.6.32-642.13.1.el6.x86_64 #1 SMP Wed Nov 23 16:03:01 EST 2016 x86_64 x86_64 x86_64 GNU/Linux

I am running below command as "root" user
rpm -i splunk-6.6.1-aeae3fe0c5af-linux-2.6-x86_64.rpm

0 Karma
Get Updates on the Splunk Community!

.conf24 | Day 0

Hello Splunk Community! My name is Chris, and I'm based in Canberra, Australia's capital, and I travelled for ...

Enhance Security Visibility with Splunk Enterprise Security 7.1 through Threat ...

(view in My Videos)Struggling with alert fatigue, lack of context, and prioritization around security ...

Troubleshooting the OpenTelemetry Collector

  In this tech talk, you’ll learn how to troubleshoot the OpenTelemetry collector - from checking the ...