Installation

Error in splunk 5.0 installation

Communicator

I'm getting the following errors displayed on WebInterface after the installation of Splunk 5.0. I have not yet configured anything on splunk
Misconfigured view 'report_builder_display' - Unknown parameter 'renderPDF' is defined for module ResultsActionButtons. Make sure the parameter is specified in ResultsActionButtons.conf.
Misconfigured view 'flashtimeline' - Parameter 'entityName' must be set to one of ['events', 'results', 'settings'] for module Paginator
Misconfigured view 'flashtimeline' - Parameter 'entityName' must be set to one of ['events', 'results', 'scanned'] for module ResultsHeader
Misconfigured view 'flashtimeline' - Unknown parameter 'enableFieldDiscoveryControls' is defined for module DisableRequiredFieldsButton. Make sure the parameter is specified in DisableRequiredFieldsButton.conf.
Misconfigured view 'job_management' - Unknown parameter 'selectUsingValue' is defined for module EntitySelectLister. Make sure the parameter is specified in EntitySelectLister.conf.

1 Solution

Splunk Employee
Splunk Employee

Might as well mark this as answered... Sounds like this was a partial uninstall, meaning the product was uninstalled but the directories/some files were not removed, and this left the configuration in an odd state after reinstall.

The solution was to delete the Splunk directory (after uninstall), and THEN reinstall.

View solution in original post

Splunk Employee
Splunk Employee

I had problems to start Splunk 5 with the port 8089 after uninstalling 4.3 and install 5. Splunk start was reporting that the port 8089 was bound and cannot be used. After restart Linux, the ./splunk start worked smoothly and the issue was solved. I am not sure, but, this error might be caused when I installed the product or delete the splunk dir without stopping services (splunkd and splunkweb) and the mentioned port perhaps was blocked by the old splunk process.

0 Karma

Splunk Employee
Splunk Employee

Yes if you delete Splunk while the process is still running the port will continue to be bound.

0 Karma

Splunk Employee
Splunk Employee

Might as well mark this as answered... Sounds like this was a partial uninstall, meaning the product was uninstalled but the directories/some files were not removed, and this left the configuration in an odd state after reinstall.

The solution was to delete the Splunk directory (after uninstall), and THEN reinstall.

View solution in original post

Communicator

I installed in on linux. I was able to remove the error by removing all the folders and re installing it again.

0 Karma

Splunk Employee
Splunk Employee

In addition to what Matt asked for - if you really want to do a fresh install, you should 1) uninstall, 2) delete the splunk installation directory, 3) install.

Splunk Employee
Splunk Employee

Can you share some details on the install? What platform are you on (linux, windows, etc.)? What is the method of removal that you used? What was the method of installation of the old version as well as 5.0?

0 Karma

Communicator

An Fresh install but I removed the older version and installed the newer one .

0 Karma

Splunk Employee
Splunk Employee

Is a completely fresh install, or an upgrade?