Getting Data In

rebalance_primaries fails with a 404 returncode

mbstein
Engager

We're new to clusters, so probably we made a stupid mistake or did not yet read an important chapter in the manual.
Trying to use the REST API on the clustermaster to redistribute primary buckets on a new cluster with version 6.0.1 we get a 404 response (the only one NOT in the manual).
What could be possibly do (in addition to sending anything through a loadbalacing forwarder and wait for a few month) ?

HTTP/1.1 404 Not Found
...
Server: Splunkd

<?xml version="1.0" encoding="UTF-8"?>
<response>
  <messages>
    <msg type="ERROR">In handler 'clustermastercontrol': Invalid action for this internal handler (handler: clustermastercontrol, supported: list|doc, wanted: edit).</msg>
  </messages>
</response>
0 Karma

mbstein
Engager

adding another "/control/" to the request helped a lot
If in doubt, cut & paste the complete URL

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...

Federated Search for CloudWatch Unified Data Store Is Generally Available

As organizations modernize their cloud environments, AWS workloads generate more security, operational, and ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...