Getting Data In

rebalance_primaries fails with a 404 returncode

mbstein
Engager

We're new to clusters, so probably we made a stupid mistake or did not yet read an important chapter in the manual.
Trying to use the REST API on the clustermaster to redistribute primary buckets on a new cluster with version 6.0.1 we get a 404 response (the only one NOT in the manual).
What could be possibly do (in addition to sending anything through a loadbalacing forwarder and wait for a few month) ?

HTTP/1.1 404 Not Found
...
Server: Splunkd

<?xml version="1.0" encoding="UTF-8"?>
<response>
  <messages>
    <msg type="ERROR">In handler 'clustermastercontrol': Invalid action for this internal handler (handler: clustermastercontrol, supported: list|doc, wanted: edit).</msg>
  </messages>
</response>
0 Karma

mbstein
Engager

adding another "/control/" to the request helped a lot
If in doubt, cut & paste the complete URL

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...