Getting Data In

Timestamp to Date Conversion

apautz22
Loves-to-Learn Lots

I'm having an issue with a dashboard which is reporting UPC counts by day.
If I use the following query, it gives the UPC counts, but not the date

<query>index=web  clientApp=MOBILE enterpriseId=prod locationID=Lima country=US command=item tagName=REMOTE_REQUEST | top 0 showperc=f message.request.payload.upc | rename message.request.payload.upc as "UPC", count as "Count"</query>

If I add the timestamp into it like the following query, then it gives the count for every UPC as 1 because they have a unique timestamp.

<query>index=web  clientApp=MOBILE enterpriseId=prod locationID=Lima country=US command=item tagName=REMOTE_REQUEST | top 0 showperc=f message.request.payload.upc message.request.payload.Time | rename message.request.payload.upc as "UPC", count as "Count"</query>

I have tried every way i can find with eval and strptime and strftime to get it to give me just the year, month, day format, but I can't get it to show that.

Admittedly I'm a noob, but I have searched for a couple days trying to find an answer and can't.

0 Karma
1 Solution

woodcock
Esteemed Legend

Try this:

index=web  clientApp=MOBILE enterpriseId=prod locationID=Lima country=US command=item tagName=REMOTE_REQUEST
| bin _time span=1d
| top 0 showperc=f message.request.payload.upc BY _time
| rename message.request.payload.upc AS UPC count AS Count

Or this:

index=web  clientApp=MOBILE enterpriseId=prod locationID=Lima country=US command=item tagName=REMOTE_REQUEST
| bin _time span=1d
| stats count AS Count BY message.request.payload.upc _time
| rename message.request.payload.upc AS UPC
| sort 0 - Count

View solution in original post

0 Karma

woodcock
Esteemed Legend

Try this:

index=web  clientApp=MOBILE enterpriseId=prod locationID=Lima country=US command=item tagName=REMOTE_REQUEST
| bin _time span=1d
| top 0 showperc=f message.request.payload.upc BY _time
| rename message.request.payload.upc AS UPC count AS Count

Or this:

index=web  clientApp=MOBILE enterpriseId=prod locationID=Lima country=US command=item tagName=REMOTE_REQUEST
| bin _time span=1d
| stats count AS Count BY message.request.payload.upc _time
| rename message.request.payload.upc AS UPC
| sort 0 - Count
0 Karma

apautz22
Loves-to-Learn Lots

They both worked - thank you very much for the assistance 🙂

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...