Getting Data In

Stop sending

aalhabbash1
Path Finder

Hi Splunker;

How to detected a index stop receiving logs from any technology last 2 hours, I need for indexes not sourcetype?

Appreciate your support.

Best Regards;

Tags (1)
0 Karma
1 Solution

koshyk
Super Champion

the best way is to see when the last time you got the data into the index and see if that time is > 2 hours

|tstats latest(_time) as latest_event WHERE (index=* OR index=_*) by index
|eval timeDiff=now() - latest_event
| where timeDiff > 7200

it should show any index which has not recieved data in last 7200 secs (i.e 2hrs)

View solution in original post

koshyk
Super Champion

the best way is to see when the last time you got the data into the index and see if that time is > 2 hours

|tstats latest(_time) as latest_event WHERE (index=* OR index=_*) by index
|eval timeDiff=now() - latest_event
| where timeDiff > 7200

it should show any index which has not recieved data in last 7200 secs (i.e 2hrs)

aalhabbash1
Path Finder

Mr.Koshyk

Done; many thank you, this is which I want, appreciate that

Best Regards;

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...