Getting Data In

Sort results by time events

mysicksi
Path Finder

Hi everyone,

Can someone please help with a search I'm trying to create. My end goal is to capture which user account logged into the server and have a time associated with their login.

My search so far is below. This only gives me the count of how many times the users logged in for the past "x" days.

  index="wineventlog" host="Redacted" source="XmlWinEventLog:Security" | stats count by SubjectUserSid
0 Karma
1 Solution

to4kawa
Ultra Champion
0 Karma

to4kawa
Ultra Champion

use timechart

0 Karma

mysicksi
Path Finder

Thank you.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...