Getting Data In

Sort results by time events

mysicksi
Path Finder

Hi everyone,

Can someone please help with a search I'm trying to create. My end goal is to capture which user account logged into the server and have a time associated with their login.

My search so far is below. This only gives me the count of how many times the users logged in for the past "x" days.

  index="wineventlog" host="Redacted" source="XmlWinEventLog:Security" | stats count by SubjectUserSid
0 Karma
1 Solution

to4kawa
Ultra Champion
0 Karma

to4kawa
Ultra Champion

use timechart

0 Karma

mysicksi
Path Finder

Thank you.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Developer Spotlight with Denis Gladkikh

From Splunk Engineer to Kubernetes App Builder Denis GladkikhWhat happens when a lifelong developer turns a ...

Governing Enterprise AI, Bringing Cisco Telemetry Home, and More from Splunk Lantern

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

Agentic SOC Triage: Investigating Splunk ES Notables with MCP Server and a Local LLM

The Problem: Too Many Alerts, Too Little Context Security operations teams running Splunk Enterprise Security ...