Getting Data In

Is the universal forwarder 8.0 supported on Windows 2012 R2?

Engager

The Forwarder Manual 8.0's mention of system requirements links to the Splunk Enterprise Installation Manual 8.0, which only lists 2016 and 2019. But I'm unclear if that just means that running the indexers/search heads are only supported on the newer windows, or if that means that the forwarder too is only supported on the newer version.

Has Windows 2012 R2 support been dropped from the Universal Forwarder 8.0?

0 Karma
1 Solution

Legend

Hi @andy7707,
No this version of Operative System is deprecated, as you can see at https://docs.splunk.com/Documentation/Splunk/8.0.0/ReleaseNotes/DeprecatedFeatures

The last certified version on Windows 2012 R2 is 7.3.3.

Ciao.
Giuseppe

View solution in original post

0 Karma

New Member

A bug you might like to fix, if you run the installer silently, via msiexec.exe /i splunkforwarder-8.0.3-a6754d8441bf-x64-release.msi AGREETOLICENSE=yes /passive, then the 8.0.3 version of Splunk UF installs on Windows 2012 R2.

I haven't tried running the installer interactively, but I know it doesn't abort the install on 8.0.3 on the unsupported OS. I was testing an upgrade script that had 7.3.5 and 8.0.3 in the package, initially I had a bug in the selection of the right UF to install, and found that it installed 8.0.3 on a Windows 2012 R2 server fine.

0 Karma

Legend

Hi @andy7707,
No this version of Operative System is deprecated, as you can see at https://docs.splunk.com/Documentation/Splunk/8.0.0/ReleaseNotes/DeprecatedFeatures

The last certified version on Windows 2012 R2 is 7.3.3.

Ciao.
Giuseppe

View solution in original post

0 Karma

Engager

Thank you. The "Removed operating Systems in version 8.0" section of that document is perfectly clear.

0 Karma