Getting Data In
Highlighted

How to configure a forwarder so it does not forward any data that appeared while the forwarder was stopped?

Path Finder

Sometimes due to a space issue, we have to stop the forwarder from sending data to Splunk.
However, when we start the forwarder, it sends the data which was not indexed during the time it was stopped.

Our requirement is, when we start the forwarder, it should not send the un-indexed data and just start sending fresh data to Splunk.

0 Karma
Highlighted

Re: How to configure a forwarder so it does not forward any data that appeared while the forwarder was stopped?

Splunk Employee
Splunk Employee

Do you have indexer acknowledgment enabled in outputs.confon the forwarder? It is disabled by default, but from your description of the behavior, it sounds as if it is enabled. See Protect against loss of in-flight data in the Forwarding Data manual.

View solution in original post

0 Karma