Getting Data In

How to configure a forwarder so it does not forward any data that appeared while the forwarder was stopped?

ayushchoudhary
Path Finder

Sometimes due to a space issue, we have to stop the forwarder from sending data to Splunk.
However, when we start the forwarder, it sends the data which was not indexed during the time it was stopped.

Our requirement is, when we start the forwarder, it should not send the un-indexed data and just start sending fresh data to Splunk.

0 Karma
1 Solution

ChrisG
Splunk Employee
Splunk Employee

Do you have indexer acknowledgment enabled in outputs.confon the forwarder? It is disabled by default, but from your description of the behavior, it sounds as if it is enabled. See Protect against loss of in-flight data in the Forwarding Data manual.

View solution in original post

0 Karma

ChrisG
Splunk Employee
Splunk Employee

Do you have indexer acknowledgment enabled in outputs.confon the forwarder? It is disabled by default, but from your description of the behavior, it sounds as if it is enabled. See Protect against loss of in-flight data in the Forwarding Data manual.

0 Karma
Get Updates on the Splunk Community!

Using Machine Learning for Hunting Security Threats

REGISTER NOW Seeing the exponential hike in global cyber threat spectrum, organizations are now striving more ...

Security Highlights | November 2022 Newsletter

 November 2022 2022 Gartner Magic Quadrant for SIEM: Splunk Named a Leader for the 9th Year in a RowSplunk is ...

Platform Highlights | November 2022 Newsletter

 November 2022 Skill Up on Splunk with our New Builder Tech Talk SeriesCan you build it? Yes you can! *play ...