Getting Data In

Why am I getting forwarder error "TailReader - File will not be read, seekptr checksum did not match" and how can I fix this?

kawashita_t
Explorer

■ErrorMessages
01-20-2016 16:35:21.999 +0900 ERROR TailReader - File will not be read, seekptr checksum did not match (file=path\DhcpSrvLog-Wed.log). Last time we saw this initcrc, filename was different. You may wish to use larger initCrcLen for this sourcetype, or a CRC salt on this source. Consult the documentation or file a support case online at http://www.splunk.com/page/submit_issue for more info.

■inputs.conf
[monitor://path]
disabled = false
index = main
host = ***
sourcetype = DHCP
whitelist = DhcpSrvLog-Wed.log
crcSalt = TestDHCP

■props.conf
[DHCP]
CHARSET = SHIFT-JIS
DATETIME_CONFIG =
NO_BINARY_CHECK = true
category = Custom
disabled = false
pulldown_type = true

0 Karma

jplumsdaine22
Influencer

You have crcSalt = TestDHCP in your props.conf

I would remove the crcSalt setting entirely unless you are sure you need it (then restart splunk)

Alternatively, set it to

crcSalt = <SOURCE>

See the section labelled crcSalt at http://docs.splunk.com/Documentation/Splunk/6.3.2/Admin/Inputsconf

0 Karma
Get Updates on the Splunk Community!

Set Up More Secure Configurations in Splunk Enterprise With Config Assist

This blog post is part 3 of 4 of a series on Splunk Assist. Click the links below to see the other ...

Observability Highlights | November 2022 Newsletter

 November 2022Observability CloudEnd Of Support Extension for SignalFx Smart AgentSplunk is extending the End ...

Enterprise Security Content Update (ESCU) v3.54.0

The Splunk Threat Research Team (STRT) recently released Enterprise Security Content Update (ESCU) v3.54.0 and ...