Getting Data In

Error while adding standalone indexer to search head cluster

Prakash493
Communicator

Hi , We have a distributed deployment environment , we have 6 indexers clustered , we have 3 search head clustered , we are adding a standalone new indexer , we are not adding this indexer to the existing cluster.

We want the data that is lying on this standalone indexer to be searchable from our search head cluster , I tried to add it through GUI by going to distributed search but after adding it to one search head, its got added successfully, while I am trying it to add to other search heads its not adding- it's saying it encountered the following error while trying to save:

Failed to proxy search-server command request to Captain. Reason : ERROR: A peer with uri of https://xxxx already exists.

Please help me.

0 Karma
1 Solution

adonio
Ultra Champion
0 Karma

adonio
Ultra Champion
0 Karma

Prakash493
Communicator

added the indexer address to the host file of the sh , Because the dns name is not able to resolved.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Self-Healing Pipeline Is Now Generally Available: AI-Powered CIM Compliance

Maintaining data integrity across security and analytics pipelines is an ongoing challenge. Data ...

Meet Splunk Observability Studio: AI-Assisted OpenTelemetry Instrumentation Without ...

Instrumentation is usually the last step or even an afterthought when building out a project. The feature ...

Federated Search for Cisco Security and Analytics Logging (SAL) is now GA on Splunk ...

Federated Search for Cisco  Security Analytics and Logging (SAL) is now generally available as part of the ...