Getting Data In

Data including double quotation mark processed by Splunk.

hanawa
New Member

I’m writing to ask how to process data including double quotation mark.

When I process data including double quotation mark as TSV file, I see unintended consequences as below.

Column1 AAA
Column2 B"BB
Column3 CCC
Column4 DD"D
Column5 EEE

Column1 AAA
Column2 B"BB CCC DD"D
Column3 EEE
Column4
Column5

Could you please tell me the way to not see double quotation as special character or to clear the quotation?

Tags (1)
0 Karma

richgalloway
SplunkTrust
SplunkTrust

Try putting FIELD_QUOTE= (no value) in the appropriate props.conf stanza.

---
If this reply helps you, Karma would be appreciated.
0 Karma

hanawa
New Member

Thanks.

An error occurred.

04-09-2017 00:09:09.141 +0900 ERROR IndexedExtractionsConfig - Error configuring indexed extracions: Invalid value='' for parameter='FIELD_QUOTE', must be at least one character., disabling them

I made the following settings.

TRUNCATE = 25000
KV_MODE = none
TIME_PREFIX = ^([^\t]*\t){11}
TIME_FORMAT = %s
SHOULD_LINEMERGE = true
MUST_NOT_BREAK_AFTER = [^ENDENDEND]$
MUST_BREAK_AFTER = ENDENDEND$
REPORT-ALARMMGR = REPORT-ALARMMGR
FIELD_QUOTE =

0 Karma

richgalloway
SplunkTrust
SplunkTrust

Interesting. Try setting FIELD_QUOTE to a character that doesn't appear in your input. Perhaps '~'.

---
If this reply helps you, Karma would be appreciated.
0 Karma
Get Updates on the Splunk Community!

The Splunk Success Framework: Your Guide to Successful Splunk Implementations

Splunk Lantern is a customer success center that provides advice from Splunk experts on valuable data ...

Splunk Training for All: Meet Aspiring Cybersecurity Analyst, Marc Alicea

Splunk Education believes in the value of training and certification in today’s rapidly-changing data-driven ...

Investigate Security and Threat Detection with VirusTotal and Splunk Integration

As security threats and their complexities surge, security analysts deal with increased challenges and ...