Getting Data In

Calculating time difference between two fields of the same name in two sourcetypes

asarolkar
Builder

All,

I have two logs with sourcetype="alphalog" and sourcetype="betalog" with the generic timestamp _time present.

I am joining them on a field called accountId.

What I want to do is to be able to find the difference between the "_time" values if possible ?

How do I find the time difference (epoch time is fine too) between two _time values in two difference log files ?

Tags (3)
0 Karma
1 Solution

alacercogitatus
SplunkTrust
SplunkTrust

Although it might not be the fastest, you can use "transaction".

sourcetype="alphalog" OR sourcetype="betalog" | transaction accountId maxspan=10m| timechart duration by accountId

Transaction calculates the duration in seconds for each transaction.

You can also do a stats and eval:

sourcetype="alphalog" OR sourcetype="betalog" | stats latest(_time) as lt earliest(_time) as et by accountId| eval duration = lt - et| table duration accountID

View solution in original post

alacercogitatus
SplunkTrust
SplunkTrust

Although it might not be the fastest, you can use "transaction".

sourcetype="alphalog" OR sourcetype="betalog" | transaction accountId maxspan=10m| timechart duration by accountId

Transaction calculates the duration in seconds for each transaction.

You can also do a stats and eval:

sourcetype="alphalog" OR sourcetype="betalog" | stats latest(_time) as lt earliest(_time) as et by accountId| eval duration = lt - et| table duration accountID

kallu
Communicator

It's all in manuals 🙂

Let's say you have a set of events where the IP address is extracted to either clientip or ipaddress. This example defines a new field called ip, that takes the value of either clientip or ipaddress, depending on which is not NULL (exists in that event):

... | eval ip=coalesce(clientip,ipaddress)

http://docs.splunk.com/Documentation/Splunk/latest/SearchReference/CommonEvalFunctions

asarolkar
Builder

Hi,

I have a stupid question for followup 🙂 !

What if the field was named accountNumber in alphalog and accountId in betalog, how would the searches that you suggested change (obviously a join is involved)

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...