Deployment Architecture

Splunk 5.0.8 + DBX 1.1.4: Failure in loading Java Bridge Server Status

ww9rivers
Contributor

This seems to be a problem on this particular search head -- similar setup works on a different search head, although running Splunk DB Connect 1.1.1.

On this one, when I go to "/en-US/app/dbx/dbxstatus", the page goes into a loading loop.

I stopped the page loading in Firebug and I saw that one request is getting a 401 error from Splunk:

Splunk DBX 401

I found the error logs in the search head's "web_access.log":

"GET /en-US/custom/dbx/dbx/status?nocache=1404229064277 HTTP/1.1" 401 1191

Any thoughts on how I should go about troubleshooting this?

0 Karma
1 Solution

sroback_splunk
Splunk Employee
Splunk Employee

Hi.This is a known issue which can occur when upgrading the app. See DB Connect Release Notes, known issue (DBX-375): http://docs.splunk.com/Documentation/DBX/1.1.1/ReleaseNotes/Releasenotes#Known_issues

A workaround is to stop the Java Bridge Server, backup all local files, then do a fresh installation of the latest version of the app (DBX 1.1.4). For details, see: http://docs.splunk.com/Documentation/DBX/1.1.1/DeployDBX/Troubleshoot#Problem_upgrading_from_earlier...

View solution in original post

sroback_splunk
Splunk Employee
Splunk Employee

Hi.This is a known issue which can occur when upgrading the app. See DB Connect Release Notes, known issue (DBX-375): http://docs.splunk.com/Documentation/DBX/1.1.1/ReleaseNotes/Releasenotes#Known_issues

A workaround is to stop the Java Bridge Server, backup all local files, then do a fresh installation of the latest version of the app (DBX 1.1.4). For details, see: http://docs.splunk.com/Documentation/DBX/1.1.1/DeployDBX/Troubleshoot#Problem_upgrading_from_earlier...

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...