Deployment Architecture

SmartStore configuration

oscar84x
Contributor

Hello everyone.

I'm testing a SmartStore configuration and I'm getting some errors when Splunk tries to move the buckets to the remote storage, which I suspect have to do with authentication. The endpoint provided to me is “<bucket_name>.s3-accesspoint.us-east-1.amazonaws.com" and I'm trying to confirm if I should be using http or https. The CacheManger and S3Client errors I'm getting are, using http "status=failed, reason="HTTP Error 307: Temporary Redirect"", and using https "status=failed, reason="HTTP Error 400: Bad Request""

This is my volume and index configuration. I was wondering if anyone could spot any obvious config errors or point me in the right direction.

 

[volume:s3]
storageType = remote
path = s3://<bucket_name>/
remote.s3.endpoint = https://<bucket_name>.s3-accesspoint.us-east-1.amazonaws.com
remote.s3.access_key = <access_key>
remote.s3.secret_key = <secret_key>

[smartstore_test]
remotePath = volume:s3/smartstore_test
##retention settings##
maxGlobalDataSizeMB = 0
#38 months
frozenTimePeriodInSecs = 99900000
repFactor = auto
homePath = $SPLUNK_DB/smartstore_test/db
thawedPath = $SPLUNK_DB/smartstore_test/thaweddb
coldPath = $SPLUNK_DB/smartstore_test/colddb

 

 

 

 

 

Labels (1)
0 Karma
Get Updates on the Splunk Community!

Detecting Remote Code Executions With the Splunk Threat Research Team

WATCH NOWRemote code execution (RCE) vulnerabilities pose a significant risk to organizations. If exploited, ...

Enter the Splunk Community Dashboard Challenge for Your Chance to Win!

The Splunk Community Dashboard Challenge is underway! This is your chance to showcase your skills in creating ...

.conf24 | Session Scheduler is Live!!

.conf24 is happening June 11 - 14 in Las Vegas, and we are thrilled to announce that the conference catalog ...