Deployment Architecture

Getting request timed out error when I launch the Splunk console in browser after a fresh Splunk install on a new Linux VM?

harishmeetsu
Explorer

I started Splunk on a Linux VM on virtual box. I am trying to browse the Splunk console using http://:8000 after the daemon is started and it gives the request timed out error in the browser. What could be the reason? Any help is appreciated.

0 Karma
1 Solution

sirkgm14vg
Explorer

Let's start with basic troubleshooting:

  • Check to see if splunk is running: ps -ef | grep splunk
  • Check to see if splunk is running on the port you think it is: netstat -tulpn

Which OS are you using?
If you are using CentOS, check to make sure firewalld is not started and also check to see if selinux is running. Disable those and see if you can see if Splunk Web works then.

You can also comment on which user you installed Splunk as, anything but root without the actual requirement of being a separate user might be your issue also.

Let's start there and then see what we can find out!

-Kristerpher

View solution in original post

0 Karma

sirkgm14vg
Explorer

Let's start with basic troubleshooting:

  • Check to see if splunk is running: ps -ef | grep splunk
  • Check to see if splunk is running on the port you think it is: netstat -tulpn

Which OS are you using?
If you are using CentOS, check to make sure firewalld is not started and also check to see if selinux is running. Disable those and see if you can see if Splunk Web works then.

You can also comment on which user you installed Splunk as, anything but root without the actual requirement of being a separate user might be your issue also.

Let's start there and then see what we can find out!

-Kristerpher

View solution in original post

0 Karma

harishmeetsu
Explorer

I meant to say "http://servername:8000"

0 Karma

jeremiahc4
Builder

Also, are you attempting to connect from within the same Linux VM setup or outside from another host? You could be dealing with a firewall blocking you out. Ensure you have enabled that port in your firewall setup.

0 Karma

Raghav2384
Motivator

What does the splunkd.log say?

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.