Deployment Architecture

Error while adding search peer to search head

aksharp
Explorer

I'm getting the below error when adding a distributed search peer to search head on CLI or GUI.

/opt/splunk/bin/splunk add search-server x.x.x.x:8089 -auth admin:password -remoteUsername admin -remotePassword password
Invalid action for this internal handler (handler: distsearch-peer, supported: list|edit|remove|_reload|new|disable|enable|doc, wanted: create).

i'm able to connect to the indexer server via nc and there are no network or firewall blocks.

Tags (1)
0 Karma
1 Solution

aksharp
Explorer

Thanks for the help.
The problem was with the permissions on the trusted.pem, changing ownership and giving it to app account solved the error.
It was not showing any errors in splunkd.log on SH or on the indexer when adding the peer. It was throwing error at splunk startup on SH, which made it a little confusing.

View solution in original post

0 Karma

aksharp
Explorer

Thanks for the help.
The problem was with the permissions on the trusted.pem, changing ownership and giving it to app account solved the error.
It was not showing any errors in splunkd.log on SH or on the indexer when adding the peer. It was throwing error at splunk startup on SH, which made it a little confusing.

0 Karma

mtaher
Loves-to-Learn

I am facing the same issue, can you please explain this in detail:

"changing ownership and giving it to app account"

0 Karma

sudosplunk
Motivator

Just making sure, are you running this command on search head? If so, can you see any error or warning messages in splunkd.log when trying to add search to search head?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...