Dashboards & Visualizations

Single Value: Current Server RAM Usage

mxanareckless
Path Finder

I need a Single Value widget for a dashboard which displays current RAM usage in real-time.
This is what I have so far in SPL:

index=index host=host sourcetype=vmstat memUsedMB=*
| stats count

And this is all I'm getting:

mxanareckless_0-1612998574373.png

How can I get something more like this? :

mxanareckless_1-1612998636785.png

 

Labels (3)
0 Karma
1 Solution

manjunathmeti
Champion

hi @mxanareckless,
Check if this works for you.

<dashboard>
  <label>Memory Usage</label>
  <row>
    <panel>
      <single>
        <title>Memory</title>
        <search>
          <query>index=index host=host sourcetype=vmstat memUsedMB=*
| stats latest(memUsedMB) as memUsedMB
| eval totalMem=10000 , freeMemPerc=(100*(totalMem-memUsedMB))/totalMem</query>
          <earliest>rt-1m</earliest>
          <latest>rt</latest>
          <progress>
            <set token="perc">$result.freeMemPerc$</set>
          </progress>
        </search>
        <option name="refresh.display">progressbar</option>
        <option name="showSparkline">0</option>
        <option name="showTrendIndicator">0</option>
        <option name="underLabel">Free $perc$ %.</option>
      </single>
    </panel>
  </row>
</dashboard>

 

If this reply helps you, an upvote/like would be appreciated.

View solution in original post

manjunathmeti
Champion

hi @mxanareckless,
Check if this works for you.

<dashboard>
  <label>Memory Usage</label>
  <row>
    <panel>
      <single>
        <title>Memory</title>
        <search>
          <query>index=index host=host sourcetype=vmstat memUsedMB=*
| stats latest(memUsedMB) as memUsedMB
| eval totalMem=10000 , freeMemPerc=(100*(totalMem-memUsedMB))/totalMem</query>
          <earliest>rt-1m</earliest>
          <latest>rt</latest>
          <progress>
            <set token="perc">$result.freeMemPerc$</set>
          </progress>
        </search>
        <option name="refresh.display">progressbar</option>
        <option name="showSparkline">0</option>
        <option name="showTrendIndicator">0</option>
        <option name="underLabel">Free $perc$ %.</option>
      </single>
    </panel>
  </row>
</dashboard>

 

If this reply helps you, an upvote/like would be appreciated.

renjith_nair
Legend

Probably you should use

index=index host=host sourcetype=vmstat memUsedMB=*
| timechart max(memUsedMB) as memUsedMB

 

---
What goes around comes around. If it helps, hit it with Karma 🙂
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...