Dashboards & Visualizations

Results not populating only in dashboard studio

aohls
Contributor

I am working on migrating some items over to dashboard studio. I have a very simple stats command getting a few counts. One item I have is to just get an average response time, avg(responseTime). When I put this into my search the column doesnt get results, other columns like count(eval(status=OK)) populate fine. Also if select to run the item as just a search it works fine and all my data shows. Anyone else have similar issues?

Labels (1)
0 Karma

elizabethl_splu
Splunk Employee
Splunk Employee

Hi @aohls does the same search work if you apply it to another visualization in the dashboard, like a table? Would you be willing to share the dashboard definition so I can take a look? You can also send it to dashboard-studio@splunk.com instead of posting here. 

0 Karma

ryanoconnor
Builder

Is it possible for you to share the entire search? I've built quite a few dashboards using this framework and would be curious to troubleshoot what might be going on here. 

0 Karma

aohls
Contributor

Its a pretty straightforward search. Below is the search just with made up names for things.

 

 

 

index=service
|stats count as "Total", avg(reponse) as "Response" by Request
|eval Response=round(Response,2)
| table Request, Total, Response 

 

 

 

I don't see anything for Response in the dashboard but once I click the magnifying glass to the search tab I see everything for that column. I have the first line as the base search and the rest as a chain referencing that base search. If I move everything to a single search it works fine though.

0 Karma

themessik
New Member

Have you been able to solve this?

I'm on 9.4.4 and experience the same error with an extremely rudimentary search

index=my_index host IN (foo,bar,baz)
| table _time host ComputerName Account_Domain EventCode eventtype name category severity_id severity Type

All fields after host refuse to populate in Dashboard Studio, but they populate in search AND in Classic Dashboards

0 Karma

elizabethl_splu
Splunk Employee
Splunk Employee

Hi @themessik  is your query 1 search, or is it broken into a base and chain search? 

0 Karma

themessik
New Member

Hi,

Base search, this is still on the Classic XML Dashboards.

Weird thing is, I haven't touched the thing in a week and during checking for you I see that the tables have started populating correctly... Which is odd to say the least.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...