Dashboards & Visualizations

How can use map command ?

rasty
Path Finder

Hi All,

index="deneme_index6" | spath output=QueryName path="CxXMLResults.Query{@name}" | mvexpand QueryName | table QueryName | map search="search index='deneme_index6' CxXMLReports.Query{@name}=$QueryName$ | table CxXMLReports.Query{@name}"

Just I'm making examples, There is not specific reason of above operation, I just try to understand. Why I'm getting error like "No results found."

Tags (1)
0 Karma
1 Solution

niketn
Legend

@rasty, I have provided another answer with Run Anywhere Example for your previous question: https://answers.splunk.com/answers/642422/xml-nested-field-issues.html

Can you please try out and confirm? Also since this question is on similar lines to your previous question, please confirm whether we can close this one.

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"

View solution in original post

0 Karma

niketn
Legend

@rasty, I have provided another answer with Run Anywhere Example for your previous question: https://answers.splunk.com/answers/642422/xml-nested-field-issues.html

Can you please try out and confirm? Also since this question is on similar lines to your previous question, please confirm whether we can close this one.

____________________________________________
| makeresults | eval message= "Happy Splunking!!!"
0 Karma

rasty
Path Finder
0 Karma

logloganathan
Motivator

Could you please try this query

index="deneme_index6" | spath output=QueryName path="CxXMLResults.Query{@name}" | mvexpand QueryName | table QueryName | map search="search index='deneme_index6' CxXMLReports.Query{@name}=$QueryName$ | table CxXMLReports.Query{@name}" maxsearches=10

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...