All Apps and Add-ons
Highlighted

Why won't the Splunk Add-on Builder load?

Explorer

I have installed the Splunk Add-on Builder and CIM components in my test environment. The plan is to develop an app for a specific piece of software; however, when I first load the Add-on Builder app, it pops up asking whether I want to send feedback to Splunk. I check the box appropriately, but then the tab_home page loads but there is no real content. I can see the header saying Splunk Add-on Builder on the right side of the page but the content below is empty (see below). I have tried to reinstall and remove every fragment of the existing installation, but it doesn't make a difference.
alt text

Splunk 6.6.2.

Highlighted

Re: Why won't the Splunk Add-on Builder load?

Explorer

I'm also getting any error: Unable to initialize modular input "validationmi" defined inside the app "splunkappaddon-builder": Introspecting scheme=validationmi: script running failed (exited with code 255).

0 Karma
Highlighted

Re: Why won't the Splunk Add-on Builder load?

Explorer

Found the issue. So I looked in the splunkd log and found it complaining about a role that did not exist. Once I created the role the app began working. Very strange because the role wasn't even related to this app.

View solution in original post

Highlighted

Re: Why won't the Splunk Add-on Builder load?

Splunk Employee
Splunk Employee

Hey @scadaman, Nice work diagnosing your issue and thanks for providing the info to the Anwers forum for anyone else facing this issue. If you accept your own answer you can begin accumulating more karma points. 🙂 Happy Splunking!

0 Karma
Highlighted

Re: Why won't the Splunk Add-on Builder load?

Communicator

what I did was just restart splunkd service and it works again, not sure why.

0 Karma
Highlighted

Re: Why won't the Splunk Add-on Builder load?

Explorer

Thanks for the tip @lfedak

0 Karma
Highlighted

Re: Why won't the Splunk Add-on Builder load?

Explorer

What role did you create?

0 Karma
Highlighted

Re: Why won't the Splunk Add-on Builder load?

Explorer

In my case it was the winfra-admin one. However, looking at the log it should give the name of the role that is missing.

0 Karma
Highlighted

Re: Why won't the Splunk Add-on Builder load?

Explorer

@scadaman where exactly did you look to find the name of the user with the problem? I have been looking in splunkd logs and can't find any reference to a role not existing. Getting the same errors you mentioned here. I know this was a while back but do you remember? Thanks

0 Karma