All Apps and Add-ons

When using the REST API Modular input to pull logs, why are we receiving the following error: "[Errno 104] Connection reset by peer)"

pp1231234
Engager

HI All,

I have configured the Splunk Rest API Modular input to pull logs from an elastic end point. I also configured a python script in responsehandler.py to modify the logs we are receiving. We were receiving logs fine for a few days. But recently, we stopped receiving logs abruptly and then we received the below error. I'm not sure what the issue is. Restart is fixing the issue temporarily, but the same error is popping and would stop receiving logs.

ExecProcessor - message from "python /opt/splunk/etc/apps/rest_ta/bin/rest.py" Exception performing request: HTTPSConnectionPool(host=’endpoint.com’, port=443): Max retries exceeded with url: /api/query/v1/logs?limit=9999 (Caused by : [Errno 104] Connection reset by peer)
0 Karma

thambisetty
SplunkTrust
SplunkTrust

This is because the proxy is blocking the connection.

Try to use proxy in your script to handle this exception.

————————————
If this helps, give a like below.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Self-Healing Pipeline Is Now Generally Available: AI-Powered CIM Compliance

Maintaining data integrity across security and analytics pipelines is an ongoing challenge. Data ...

Meet Splunk Observability Studio: AI-Assisted OpenTelemetry Instrumentation Without ...

Instrumentation is usually the last step or even an afterthought when building out a project. The feature ...

Federated Search for Cisco Security and Analytics Logging (SAL) is now GA on Splunk ...

Federated Search for Cisco  Security Analytics and Logging (SAL) is now generally available as part of the ...