All Apps and Add-ons

When using the REST API Modular input to pull logs, why are we receiving the following error: "[Errno 104] Connection reset by peer)"

pp1231234
Engager

HI All,

I have configured the Splunk Rest API Modular input to pull logs from an elastic end point. I also configured a python script in responsehandler.py to modify the logs we are receiving. We were receiving logs fine for a few days. But recently, we stopped receiving logs abruptly and then we received the below error. I'm not sure what the issue is. Restart is fixing the issue temporarily, but the same error is popping and would stop receiving logs.

ExecProcessor - message from "python /opt/splunk/etc/apps/rest_ta/bin/rest.py" Exception performing request: HTTPSConnectionPool(host=’endpoint.com’, port=443): Max retries exceeded with url: /api/query/v1/logs?limit=9999 (Caused by : [Errno 104] Connection reset by peer)
0 Karma

thambisetty
SplunkTrust
SplunkTrust

This is because the proxy is blocking the connection.

Try to use proxy in your script to handle this exception.

————————————
If this helps, give a like below.
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...