All Apps and Add-ons

The rest api add-on works in with version 1.5.3 but when I upgrade to 1.8.1 or 1.8.2 the data stops being ingested into splunk. any idea why?

jlstanley
Path Finder

I've got about 10 or 12 rest api inputs setup in the add-on that are all working fine with 1.5.3 but stop working whenever I upgrade the add-on to 1.8.X

is there anything I need to be changing to make it work? I'm on splunk 7.3.1 currently with RHEL7.4

Labels (2)
0 Karma
1 Solution

gjanders
SplunkTrust
SplunkTrust

You will find that Splunk 7.3.x and 1.8.1 and 1.8.2 did not work, 1.8.3 fixes it
If you look at SplunkBase you will notice the baboon bones team removed 1.8.1 and 1.8.2 from the website...

View solution in original post

0 Karma

jlstanley
Path Finder

After updating to 1.8.3 it still didn't work right off the bat but I was able to finally see in the error log that I needed to copy the custom responsehandlers.py from the previous add-on to the new since it got overwritten. thank you

0 Karma

gjanders
SplunkTrust
SplunkTrust

You will find that Splunk 7.3.x and 1.8.1 and 1.8.2 did not work, 1.8.3 fixes it
If you look at SplunkBase you will notice the baboon bones team removed 1.8.1 and 1.8.2 from the website...

0 Karma
Get Updates on the Splunk Community!

2024 Splunk Career Impact Survey | Earn a $20 gift card for participating!

Hear ye, hear ye! The time has come again for Splunk's annual Career Impact Survey!  We need your help by ...

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...