All Apps and Add-ons

The rest api add-on works in with version 1.5.3 but when I upgrade to 1.8.1 or 1.8.2 the data stops being ingested into splunk. any idea why?

jlstanley
Path Finder

I've got about 10 or 12 rest api inputs setup in the add-on that are all working fine with 1.5.3 but stop working whenever I upgrade the add-on to 1.8.X

is there anything I need to be changing to make it work? I'm on splunk 7.3.1 currently with RHEL7.4

Labels (2)
0 Karma
1 Solution

gjanders
SplunkTrust
SplunkTrust

You will find that Splunk 7.3.x and 1.8.1 and 1.8.2 did not work, 1.8.3 fixes it
If you look at SplunkBase you will notice the baboon bones team removed 1.8.1 and 1.8.2 from the website...

Alerts for Splunk Admins https://splunkbase.splunk.com/app/3796/
Version Control for Splunk https://splunkbase.splunk.com/app/4355/

View solution in original post

0 Karma

jlstanley
Path Finder

After updating to 1.8.3 it still didn't work right off the bat but I was able to finally see in the error log that I needed to copy the custom responsehandlers.py from the previous add-on to the new since it got overwritten. thank you

0 Karma

gjanders
SplunkTrust
SplunkTrust

You will find that Splunk 7.3.x and 1.8.1 and 1.8.2 did not work, 1.8.3 fixes it
If you look at SplunkBase you will notice the baboon bones team removed 1.8.1 and 1.8.2 from the website...

Alerts for Splunk Admins https://splunkbase.splunk.com/app/3796/
Version Control for Splunk https://splunkbase.splunk.com/app/4355/

View solution in original post

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.