All Apps and Add-ons

Splunk on Windows - error 'cscript' is not recognized

duncanuno
Explorer

I have just installed Splunk on Windows 2008R2 and wish to collect Netflow data - installed Netflow Integrator.

When attempting to configure "Netflow Integrator Server Configuration" I get an error just below "Netflow Integrator Server Status" and just above the 3 icons for Start, Stop and Restart

Error
'cscript' is not recognized as an internal or external command, operable program or batch file.

No helpful errors generated that I can find. Server has been restarted more than once, no difference.
Any ideas?

0 Karma
1 Solution

NetFlow_Logic
Contributor

Cscript.exe is a command-line version of the Windows Script Host that provides command-line options for setting script properties. Please check that you have it here %systemroot%\system32\cscript.exe.

Then make sure the “NetFlow Integrator” user (Splunk user) has access rights to run it.

If you require any additional assistance, please submit a request at:
https://netflowlogic.zendesk.com/anonymous_requests/new

View solution in original post

0 Karma

NetFlow_Logic
Contributor

Cscript.exe is a command-line version of the Windows Script Host that provides command-line options for setting script properties. Please check that you have it here %systemroot%\system32\cscript.exe.

Then make sure the “NetFlow Integrator” user (Splunk user) has access rights to run it.

If you require any additional assistance, please submit a request at:
https://netflowlogic.zendesk.com/anonymous_requests/new

0 Karma

duncanuno
Explorer

I have created another machine with fewer restrictions and resolved this problem. Will have to spend some time to work out why additional security restrictions on server have broken the execution of cscript.exe when all appears to be in order.

duncanuno
Explorer

Thanks for that.

Environment variables appear correct -
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\

Running in a non AD windows server, logged in a local admin

Confirmed that cscript.exe has read & execute permission for Splunk user

Will pursue the permissions angle

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Cisco Data Fabric from Architecture to Investigation, Better SOC Visibility, and More ...

Splunk Lantern is Splunk’s customer success center that provides practical guidance from Splunk experts on key ...

The Trust Gap: Why a Data Foundation is Fundamental to an Agentic Enterprise

The Trust Gap: Why a data foundation is fundamental to an  Agentic Enterprise.   Agentic AI is transforming ...

Data Management Digest – September 2026

    Welcome to the September 2026 edition of Data Management Digest! September brought a fresh wave of ...