All Apps and Add-ons

Splunk Cloud Gateway setup

Explorer

Hi, I've just installed the Splunk Cloud Gateway to gain access to our Splunk Instance using the new Splunk Mobile App. Trying to Register any device is giving me an error "Oops, something went wrong. Try again later or contact your Splunk administrator". All other dashboards (Configure, Devices, Splunk > AR) of the Cloud Gateway app return generic error "We aren't able to load your application settings. Try again later or contact your Splunk administrator." . I've already assigned the Gateway role to the admin role but nothing changes. Any suggestion to fix the issue?

Thanks and regards

1 Solution

Splunk Employee
Splunk Employee

Hi Tom,

It looks to me that there is an issue with the install in particular the modular_inputs required to function aren't installed/running properly. Verify in Settings > Data Inputs that the Local Inputs are installed and enabled:

Splunk Cloud Gateway
Splunk Cloud Gateway Subscription Processor
Splunk Cloud Gateway Mobilie Alerts TTL
Splunk Cloud Gateway Role Based Notification Manager
Splunk Cloud Gateway Metrics Collector
Splunk Cloud Gateway Subscription Clean Up

Other debugging things to try are listed in our trouble shooting guide here:
https://docs.splunk.com/Documentation/Gateway/latest/Registration/TroubleshootGateway

Additionally check out the "Cloud Gateway Status Dashboard" via S&R dashboards.

View solution in original post

0 Karma

Motivator

Same. On prem 7.2 linux installation. curl https://prod.spacebridge.spl.mobi/health_check returns what it is supposed to, but ps ax | grep modular_input doesn't have anything. ugh. documentation is useless

0 Karma

Splunk Employee
Splunk Employee

if the modular_inputs aren't running please verify that they are installed and enabled. If there is anything in particular with regards to the documentation that you feel is missing we can certainly address that. Cheers.

0 Karma

Motivator

They are (now) running, rebooted, still same error. Per the documentation no clue what to try next

0 Karma

Splunk Employee
Splunk Employee

If you go to the "Cloud Gateway Status Dashboard" are there any errors listed?

0 Karma

Motivator

Yup, KV store errors. That's probably on me?

0 Karma

Splunk Employee
Splunk Employee

Yes so you'll need to make sure your user is able to read/write from kvstore and that kvstore is setup for that Search Head.

0 Karma

Splunk Employee
Splunk Employee

Hi Tom,

It looks to me that there is an issue with the install in particular the modular_inputs required to function aren't installed/running properly. Verify in Settings > Data Inputs that the Local Inputs are installed and enabled:

Splunk Cloud Gateway
Splunk Cloud Gateway Subscription Processor
Splunk Cloud Gateway Mobilie Alerts TTL
Splunk Cloud Gateway Role Based Notification Manager
Splunk Cloud Gateway Metrics Collector
Splunk Cloud Gateway Subscription Clean Up

Other debugging things to try are listed in our trouble shooting guide here:
https://docs.splunk.com/Documentation/Gateway/latest/Registration/TroubleshootGateway

Additionally check out the "Cloud Gateway Status Dashboard" via S&R dashboards.

View solution in original post

0 Karma

Explorer

Hi, all Data Inputs are installed and enabled. On S&R dashboard status is Connected and KV Store is Ready. I'm trying to check for any permission issue.

0 Karma

Explorer

I followed the same steps to install the Cloud Gateway on my local Enterprise Splunk Instance and all is working fine. I'm able to see the dashboard on my iphone.
Still remains the error on usage of the Cloud Gateway on our Splunk Cloud Instance. Any action on the Cloud Gateway dashboard end with the same error "We aren't able to load your application settings. Try again later or contact your Splunk administrator."

0 Karma

Splunk Employee
Splunk Employee

Currently there are issues installing the Cloud Gateway on a Splunk Cloud instance through SSAI so you'll need to engage your customer support portal to have the app installed manually.

0 Karma