All Apps and Add-ons

Splunk 7.3.1 DBX Oracle driver not recognized

sdevireddy1
Engager

SPLUNK_HOME=/appl/splunk

Driver is in $SPLUNK_HOME/etc/apps/splunk_app_db_connect/drivers per https://docs.splunk.com/Documentation/DBX/3.1.4/DeployDBX/ConfigureDBConnectsettings

[wamsplunk@ bin]$ cd $SPLUNK_HOME/etc/apps/splunk_app_db_connect/drivers
[wamsplunk@ drivers]$ ls -altr
total 7868
-rw-r--r--  1 wamsplunk wamsplunk      41 Sep 29 09:24 README
-rw-r--r--  1 wamsplunk wamsplunk 8048640 Sep 29 09:42 ojdbc8-full.tar
drwx------ 20 wamsplunk wamsplunk    4096 Sep 30 11:06 ..
drwxr-xr-x  2 wamsplunk wamsplunk      43 Oct  2 22:23 .

When I look at DBX-> Configuration -> settings -> Drivers .. All of them are marked X No for the Installed column including Oracle.

Any thoughts ?

0 Karma
1 Solution

jacobpevans
Motivator

Greetings @sdevireddy1,

Everything sounds right to me. Have you done this yet? The bounces should not be necessary, but I'm putting them there anyway.

  1. Bounce the instance
  2. Navigate to: "Splunk DB Connect > Configuration > Settings > Drivers > Reload"
  3. Bounce the instance

Cheers,
Jacob

Edit: I just noticed your drivers are in .tar format. Our working drivers are all in .jar format. Also try unzipping them.

Cheers,
Jacob

If you feel this response answered your question, please do not forget to mark it as such. If it did not, but you do have the answer, feel free to answer your own post and accept that as the answer.

View solution in original post

sdevireddy1
Engager

Thank you for the answer. That worked.

tar -xvf ojdbc8-full.tar gave the jar files.. but in a sub folder. I moved them to the drivers directory.

0 Karma

jacobpevans
Motivator

Glad to hear it. Thank you for marking the answer.

Cheers,
Jacob

If you feel this response answered your question, please do not forget to mark it as such. If it did not, but you do have the answer, feel free to answer your own post and accept that as the answer.
0 Karma

jacobpevans
Motivator

Greetings @sdevireddy1,

Everything sounds right to me. Have you done this yet? The bounces should not be necessary, but I'm putting them there anyway.

  1. Bounce the instance
  2. Navigate to: "Splunk DB Connect > Configuration > Settings > Drivers > Reload"
  3. Bounce the instance

Cheers,
Jacob

Edit: I just noticed your drivers are in .tar format. Our working drivers are all in .jar format. Also try unzipping them.

Cheers,
Jacob

If you feel this response answered your question, please do not forget to mark it as such. If it did not, but you do have the answer, feel free to answer your own post and accept that as the answer.
Get Updates on the Splunk Community!

Optimize Cloud Monitoring

  TECH TALKS Optimize Cloud Monitoring Tuesday, August 13, 2024  |  11:00AM–12:00PM PST   Register to ...

What's New in Splunk Cloud Platform 9.2.2403?

Hi Splunky people! We are excited to share the newest updates in Splunk Cloud Platform 9.2.2403! Analysts can ...

Stay Connected: Your Guide to July and August Tech Talks, Office Hours, and Webinars!

Dive into our sizzling summer lineup for July and August Community Office Hours and Tech Talks. Scroll down to ...