All Apps and Add-ons

How to plot data on Google Maps app?

varad_joshi
Communicator

I am using the app for Google maps and want to plot some static data on particular latitude and longitude.

Example: index=myindex| eval lat="2.068939" | eval lon="75.308099" | geostats latfield=lat longfield=lon count

Works on the default map provided by Splunk but I want to show the building and street level information too and hence using the Google maps app.

Idea is to plot these values in a look up and plot it on map.

0 Karma

alylanchester
Explorer

Try using a _geo field instead in the format:

_geo=lat,lon

I did mine in my .csv lookup file. But I hope it helps. I couldnt get it working the way you did it either- but this seemed to work.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...