All Apps and Add-ons

How to configure Platform Advisor for BMC Remedy in Splunk Enterprise

jk0061444
Explorer

Hi All

I'm trying to use the "Platform Advisor for BMC Remedy" splunk Add-ons for BMC Remedy in Splunk Enterprise.

below are the steps followed but not able to see the anything in dashboard

step 1: Downloaded Platform Advisor for BMC Remedy splunk add-ons
step 2: Placed the files under %SPLUNK_HOME%\etc\apps<>
step 3: able to see the bmc app in the url
step 4: changed input.cong in below folder locations as shown below

D:\Program Files\Splunk\etc\apps\platform_advisor_remedy\appserver\addons\rpa-inputs-ta\default
D:\Program Files\Splunk\etc\apps\platform_advisor_remedy\default

input.conf

[monitor://D:\Program Files\BMC Software\ARSystem\Arserver\Db\arerror.log]
disabled = false
sourcetype = remedy_arerror

[monitor://D:\Program Files\BMC Software\ARSystem\Arserver\Db\armonitor.log]
disabled = false
sourcetype = remedy_armonitor

Note: have installed splunk enterprise on the same server where BMC Remedy AR is installed

questions:
1) let me know if any steps i have missed out so that i can view the data
2) what about mid-tier configuration , have mid-tier on different server , how should i proceed for it

[monitor:///opt/remedy_data/mid-tier/]
disabled = true
sourcetype = remedy_midtier

Please help me out in resolving the issue

0 Karma
1 Solution

jk0061444
Explorer

found the solution after below changes its working fine

Copy the default inputs.conf file from D:\Program Files\Splunk\etc\apps\platform_advisor_remedy\default to D:\Program Files\Splunk\etc\apps\platform_advisor_remedy\local

In default folder you would be having inputs.conf.example file modify to inputs.conf and make the changes as required

View solution in original post

0 Karma

jk0061444
Explorer

found the solution after below changes its working fine

Copy the default inputs.conf file from D:\Program Files\Splunk\etc\apps\platform_advisor_remedy\default to D:\Program Files\Splunk\etc\apps\platform_advisor_remedy\local

In default folder you would be having inputs.conf.example file modify to inputs.conf and make the changes as required

0 Karma

rick_chen
New Member

Hi JK,

We no longer offer support for this product. However, as a quick debug tip:

--restart splunk and check the internal logs in %SPLUNK_HOME%\var\log\splunk\splunkd.log for any errors or warnings.
--Splunk is case sensitive, check the path and filename
--Maybe the splunk service doesn't has read permissions on the file/folder, check permissions

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>