All Apps and Add-ons

How can I remove the error "Unable to initialize modular input "jmx" defined inside the app "SPLUNK4JMX"" received on our search heads?

michael_sleep
Communicator

Hey there, we're using Monitoring of Java Virtual Machines with JMX (SPLUNK4JMX) to capture JMX data from some of our applications. Right now we're getting the following error message from the SPLUNK4JMX deployment on our search heads:

Unable to initialize modular input "jmx" defined inside the app "SPLUNK4JMX": Introspecting scheme=jmx: script running failed (exited with code 1).

The solution to this error is to install the JDK and make sure the Java home path is set but I don't believe this should apply to the search heads because they will not be making any JMX calls (we have SPLUNK4JMX on a heavy forwarder with the JDK).

The app itself actually works perfectly well on the search heads and displays the JMX data without any problems. The only issue is that the error message keeps appearing. I've tried removing various files from the app, including the bin directory but it keeps trying to initialize the JMX modular input... I can't see where that information is coming from. Anyone know the solution to this?

1 Solution

lycollicott
Motivator

Delete etc\apps\SPLUNK4JMX\README\inputs.conf.spec and restart Splunk.

*.conf.spec files define the modular inputs.

View solution in original post

lycollicott
Motivator

Delete etc\apps\SPLUNK4JMX\README\inputs.conf.spec and restart Splunk.

*.conf.spec files define the modular inputs.

michael_sleep
Communicator

Enjoy your karma.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

A Four-Part Event Series: Full Stack Observability For the AI Era

As AI reshapes applications, infrastructure, and the way teams operate, the traditional boundaries of ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...